WordPress 5.2 – a PHP programnyelv 5.6-os verziója minimum követelmény a frissítéshez!

A WordPress legújabb frissítése április végétől már elérhető. A kiadás számos újdonságot és ráncfelvarrást tartalmaz, így javításra kerül a blokkszerkesztő és néhány idegőrlő hibától is megszabadulhatunk. Következzenek a részleteket.

Mielőtt mélyelemzésbe kezdenénk a WordPress 5.2-es verziójáról, nem árt kiemelni, hogy egyelőre annak béta változata érhető el, így megeshet, hogy a végleges kiadás némileg más lesz.

A verzió ugyanis fejlesztés alatt áll, így egyes funkciók kimaradhatnak, illetve egyes funkciókkal bővülhet a nagyközönség részére szánt kiadás.

Teljesen átalakult a WordPress végzetes hiba funkció

A leggyakrabban előforduló hibák közé tartoznak azok a problémák, melyek a „Végzetes hiba történt” üzenetablak megjelenítése mellett megakadályozzák, hogy a felhasználó belépjen az adminisztrációs felületre.

Ezt eddig jórészt csak egy FTP kliens segítségével, illetve a tárhelyszolgáltató megkeresésével lehetett orvosolni (mentésből visszaállítás). Most a fejlesztők azt ígérik, hogy a WordPress adminisztrátorok részére új helyreállítási módot vezetnek be.

Végzetes hiba előfordulása esetén a jövőben a weboldalon az alábbi üzenet lesz látható: „Ez az oldal technikai nehézségekkel küzd.” A WordPress pedig a telepítéskor megadott e-mail címre automatikusan küldeni fog egy speciális bejelentkezési hivatkozást, így lehetőség lesz a vezérlőfelületre bejelentkezve kijavítani a hibát.

Ráncfelvarrás alá esik a Gutenberg Blokkszerkesztő

A Gutenberg szövegszerkesztő megjelenését követően a WordPress fejlesztői kaptak hideget, meleget (de leginkább hideget). Az új editor ugyanis korántsem váltotta be a hozzá fűzött reményeket: kezelése nehézkes, kissé áttekinthetetlen és körülményes.

Érezhették ezt a fejlesztők is, hiszen a szövegszerkesztő egyik alapelemeként funkcionáló blokkszerkesztő némi újításon esett át. A teljesítményjavulás mellett következetesebb lesz, kezelése letisztul, és hatékony súgóablakok segítik majd a szerzők munkáját. Ezek mellett új blokkok bevezetésére is sor került: RSS-blokkok, Amazon Kindle beágyazott blokkok, keresési blokkok, naptárblokkok és címkefelhő blokkok is megtalálhatók az 5.2-es frissítésben.

A tervek szerint továbbá új blokk hozzáadására, illetve a nem használtak eltávolítására is lehetőség nyílik majd.

Minimális PHP követelmény

Óriási újításként tarthatjuk számon, hogy a WordPress 5.2-es frissítése már nem elégszik meg a PHP programnyelv 5.6-os verziójánál régebbi kiadással. Ez azt jelenti, hogy ha a WordPress tartalomkezelő rendszer alatt régebbi PHP változat fut, akkor az adminisztrátor nem tudja majd a WP 5.2-re frissíteni a weboldalát. (A legfrissebb stabil PHP verzió egyébként a 7.3.2-es.)

Az érintett webgazdák a WordPress adminisztrációs felületén fognak tájékoztatást kapni a PHP frissítés szükségességéről, illetve a további teendőkről.

Fejlesztői szintű frissítések

Az alábbi újítások vélhetően csak a WordPress fejlesztői szintű felhasználóit érintik, ugyanis az átlagemberek nagyrészt sohasem tekintenek ilyen mértékben a virtuális motorháztető alá. Ezek a következők lesznek:

  • A wp-config.php fájlhoz történő WP_DEBUG_LOG parancssor hozzáadásával a jövőben naplófájl elérési utat biztosíthatunk.
  • A bővítmények fejlesztői megadhatják az alkalmazásuk telepítéséhez szükséges minimális PHP verziót. (Vélhetően alatta nem tudjuk majd telepíteni az adott bővítményt.)
  • 25 új ikonnal bővül a baloldali, adminisztrációs felületen használható piktogramok száma (Dashicons).

Minden vélemény számít:

A szerkesztő ajánlata:

Vélemény, hozzászólás?